Hello All - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 27-04-08 Thread Starter
Status: -
Join Date: Apr 2008
Posts: 2

Member car:


Hello All

Dear All,

I m from Malaysia and have just purchased one Alfa Romeo Berlina year 1974. WOuld like further advice on parts and maintenance soon.

Great to know of this site. Thank you.

Kitto37 is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Hello All

Hi ya, welcome to AO
BigFoot is offline  
Status: -
AO Member
motoko's Avatar
Join Date: Jan 2008
Location: Wellington, New Zealand
Posts: 105
Re: Hello All

Hi and welcome to the forum!!
motoko is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: Hello All

Hello and welcome to AO
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: Hello All

Hi Kitto, congrats on your Bella post up pics and check out our classics lounge for more help and info. CheersThe Classic Alfa Romeos - Alfa Romeo Forum
classicgal93 is offline  
Status: -
Admin Team
Alfa Vincent's Avatar
Join Date: Nov 2005
Location: United Kingdom
County: Hertfordshire
Posts: 30,411
Images: 27
Re: Hello All

welcome to AO!
Alfa Vincent is offline  
(Post Link) post #7 of 9 Old 27-04-08 Thread Starter
Status: -
Join Date: Apr 2008
Posts: 2

Member car:


Re: Hello All

Good day to all, would love to post some pics of my Berlina but unfortunately the limit is just 100kb thus the failure.

Upon buying yesterday I drove drove it straight 150 km (right away) from the owner's place back to my home. Enjoyed all the way. Sending it to workshop t'row morning.

The body is infested with rust, bottom portion of doors - all four, lower left fender - quite bad, can see the road from inside. All door's panel soften, practically swinging in and out.

Nevertheless, the engine perform well all the way. The temperature gauge is constant at 80 degree - hope that's true! I can feel the charging response as I floored the accelerator. Car going towards right whenever brake's applied, thus got to be extra careful. Left lower ball joy knocking badly.

Will perform full inspection tomorrow morning to know more of the exact condition.

Btw, I paid $1K for it. Hope it's a good buy.

Good day guys,

Kitto37 is offline  
Status: Zoe FTW
AO Rosso Alfa Member
baby278278's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Essex
Posts: 46,602
Images: 49
Re: Hello All

Hello and Welcome to the forum
baby278278 is offline  
Status: Struggling on
AO Gold Member
Brickman's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: West Yorkshire
Posts: 11,614
Images: 26
Re: Hello All

Hello and welcome to AO:Bye:
Brickman is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome