147 blues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 03-02-08 Thread Starter
Status: -
Join Date: Feb 2008
Posts: 1

Member car:

147 1.6TS

Madness 147 blues

Just got my car back on Thursday night after having the clutch slave cylinder replaced (and clutch, thought I may as well do that too). Only for my timing belt to go on saturday night, still waiting to find out the damage.

Cars done 43k registered September 03 and beginning to think what's next? Am I just unlucky or is this typical of this model?
Gdogg is offline  
Sponsored Links
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Re: 147 blues

Yikes I hope it has some warrenty. Welcome to AO, lots to read in the 147 tech section.
classicgal93 is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: 147 blues

Sorry to hear that fella !!

Hello and Welcome anyhoo!!
nomad is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

147 , blues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome