GTV probs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 20-01-08 Thread Starter
Status: -
AO Member
Join Date: Oct 2007
Location: Derbyshire
Posts: 59
Images: 2
GTV probs

Hey peeps!
Have a guess what,,, I got a problem with my GTV.
Well a few actually.
First one is the temp. I changed my rotten radiator and now the car runs at about 50deg. Even after 100miles its still cold, only warms up when Im sat in traffic for about 10 mins and it'll only go to about 60 (just enough to blow a warm breeze through the vent).
Do you think its just the thermostat or could it be something else?
Secondly after replacing the MAF (previous problem) the engine now hunts on idle especially when stopping when the clutch goes down it'll rev upto 2000revs then nearly cut out then rev again (repeatedly for 10 to 15secs) before settling. This happened after the MAF sensor was changed.
Thirdly, my wipers wont swipe all the way to the right, the drivers wiper kind of stops infront of your face and doesnt go all the way to the end. After about 10mins it will work properly but if I turn the wipers off then back on the problem will start again.
Well thats about it for now as I can write a book on its probs and I'd bore you all to tears!
Cheers for any help everyone!

Alex and his poorly GTV
alexcraiggtv is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: GTV probs

Welcome to AO Alex
BigFoot is offline  
Status: - Update
Posts: n/a
Re: GTV probs

hiya Alex and welcome to AO...

Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,052
Images: 2
Re: GTV probs

Hi Alex, welcome to AO, sorry to hear about your probs.
classicgal93 is offline  
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: GTV probs

Hello and welcome to AO.
rammy is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: GTV probs

Hello and welcome
nigelread is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: GTV probs

Hello and Welcome !!
nomad is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

gtv , probs

« Hi all | Hello »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome