Battery...I think! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 17-01-08 Thread Starter
Status: -
Join Date: Jan 2008
Posts: 8
Battery...I think!

I've had a 156 2.4jtd for 3 years and have had the associated problems with suspension and various warnings flashing up from time to time but I want to try and confirm the latest problem and hope it will just take a battery replacement to fix it.

Basically the car wont start, I thought it was just the battery but I did have the flashing glow plug warning for some time but am I right in thinking the car should still start even with faulty glow plugs? For a while it was a bit slow and sluggish to start but once it had been driven was fine. I know there are a million sensors as well, crank, tpc etc but surely a new battery would solve it. After reading various posts it may help the annoying MCS failure and VDC failure warnings every now and then!!

Heres hoping.

(question posted in tech lounge)

Last edited by OperationAlfa; 18-01-08 at 09:54. Reason: Question answered in tech lounge ... OA
stewdrummond is offline  
Sponsored Links
Status: adds
AO Member
derek155's Avatar
Join Date: Jul 2007
Posts: 385
Images: 9

Member car:

164 3.0v6 super

Re: Battery...I think!

hi mate, welcome
derek155 is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: Battery...I think!

Hello and welcome
nigelread is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: Battery...I think!

Hi Stew welcome to AO.
classicgal93 is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Battery...I think!

Welcome onboard
BigFoot is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Battery...I think!

Hello and Welcome !!
nomad is offline  
Status: - Update
Posts: n/a
Re: Battery...I think!

welcome to AO...

all the best

Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: Battery...I think!

Hello and welcome to AO.
rammy is offline  
Status: Struggling on
AO Gold Member
Brickman's Avatar
Join Date: Oct 2006
Location: United Kingdom
County: West Yorkshire
Posts: 11,614
Images: 26
Re: Battery...I think!

Hello and welcome to AO:Bye:
Brickman is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


« Newbie | Howdy »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome