First Alfa - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 13-07-16 Thread Starter
Status: -
sky_blue_brera's Avatar
Join Date: Jul 2016
Location: Birmingham
County: West Midlands
Posts: 2
First Alfa

IMG_1615 (1) (1).jpg

Hi there just bought my first Alfa - a Brera 2.4 JTDM (2006), really pleased with it and just had the alloys refurbished (after this pic was taken). The colour was a big selling factor and of course the general design! Wish it did a few more MPG though as I was driving a 65 MPH Volvo C30!

I get an intermittent problem with the rear parking sensor too - some days it works others I get a warning on the dashboard telling me it's disabled. I sometimes get the same warning for the ABS.

The front windscreen wipers confuse me too - intermittent setting doesn't seem to turn off sometimes!

Oh well - for 4600 and a few quid spent on the alloys and a little patch up round the front wheel arches - I can't complain too much
sky_blue_brera is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome