Forum URL - links in - FIXED - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Announcements & Comments A lounge for staff announcements.
If we have ideas, requests or something to tell you, it will go in here.

 
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 30-03-06 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2003
Location: Up Norf (Teesside)
Posts: 520
Crazed Forum URL - links in - FIXED

Just a quicky, and a bit of a technical naughty, but in the past links to http://www.alfaowner.com/forum/ jumped straight into the forum (bypassing the main site), but now that just 404's. Whereas linking to http://www.alfaowner.com/Forum/ works, now the only difference is the case of the 'F' which is a bit naughty as ye old t'internet *should* be case sensitive.

Anyhoo, in order to preserve google rankings, links in from other sites, and generally keeping incoming traffic sweet can I suggest someone puts in a 301 (permanent) redirect, be it a script, htaccess or similar.

Even a file called index.html (assuming that's a valid index) with below code in would work (apologies if teaching granny to suck eggs )

Quote:
<html>
<head><title>Redirecting...</title>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<meta http-equiv="refresh" content="0; url=http://www.alfaowner.com/Forum/">
</head>
<body bgcolor="#ffffff" text="#FFFFFF">
</html>
Only noticed this as the frappr page has a link to our forum, which is broke, and I can't edit it cos they ******ed up!

That's all,

TIA

You're born, you live a little, you keep your head down, then you die. (Eddie Hitler - Bottom)
flish is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
phil155's Avatar
 
Join Date: Jul 2005
Location: half way up the A12
Posts: 5,093
Images: 24
Re: Forum URL - links in

just checked my bookmarks and it is marked and has been for 6 months with the capital f
phil155 is offline  
Status: -
Club Member
Membro Premio
 
Club Member Number: 1561
Join Date: Dec 2001
Location: Netherlands
County: -
Posts: 12,865
Images: 305

Member car:

busso powered

Re: Forum URL - links in

Quote:
Originally Posted by flish
Just a quicky, and a bit of a technical naughty, but in the past links to http://www.alfaowner.com/forum/ jumped straight into the forum (bypassing the main site), but now that just 404's. Whereas linking to http://www.alfaowner.com/Forum/ works, now the only difference is the case of the 'F' which is a bit naughty as ye old t'internet *should* be case sensitive.
the forum is located in /Forum since January 2004 (with a capital F) and our site runs on an Appache webserver which makes the URL case sensitive.
selespeed is offline  
(Post Link) post #4 of 6 Old 30-03-06 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2003
Location: Up Norf (Teesside)
Posts: 520
Re: Forum URL - links in

Hmm, well I've always had it as forum, and I only created the AO Frappr map last November, and it worked then, so something has gone awol. Admittedly I assumed it was the new site, seemed a co-incidence.

Appreciate that *nix variants are case sensitive, but that's the Server OS not the majority of clients, and I know Windows isn't case sensitive so it allows the probability of whoopsies. Can't find a reference, but pretty sure standards say you should normalise down to lowercase to be safe, but that's your call. Just pointing it out.

STOP PRESS: Just googled for "alfaowner.com/forum" (quotes included) and you're right, most are capital F, but there are a good few that are lower case f, think I know where from too, the old, old forum (the cgi one) was deffo lower case, so guessing there was something redirecting old, old to old (if that makes sense!)

Either way, there are some links out there that are 404'ing, I'll fix the one I control once frappr fix their boo boo and let me!
flish is offline  
Status: -
Club Member
Membro Premio
 
Club Member Number: 1561
Join Date: Dec 2001
Location: Netherlands
County: -
Posts: 12,865
Images: 305

Member car:

busso powered

Re: Forum URL - links in

Quote:
Originally Posted by flish
.. Can't find a reference, but pretty sure standards say you should normalise down to lowercase to be safe, but that's your call. Just pointing it out.
I know and agree, but we were developping the new forum on /Forum back then while /forum was still running.

Quote:
Originally Posted by flish
.. think I know where from too, the old, old forum (the cgi one) was deffo lower case, so guessing there was something redirecting old, old to old (if that makes sense!)
That was why I mentioned January 2004 in my previous post
selespeed is offline  
Status: No more guiletta... Auctioned off
Founder of AO
 
alfaowner's Avatar
 
Join Date: Apr 2001
Location: United Kingdom
County: Essex
Posts: 8,044
Images: 83

Member car:

Maserati GTS

Re: Forum URL - links in

Hey, it does work if you go to http://www.alfaowner.com/forum but in my error and rush to set up and install board on new server a month back, I failed to add the trailing slah redirect, all is working as it did on since 2004 again. Thanks for letting us know, this error is rated high on my basic IT naughtly list, I consider myself well and truly 80110CKED
alfaowner is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Announcements & Comments

Tags
fixed , forum , links , url

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome