Strange happenings with my 3.0 v6 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 30-06-16 Thread Starter
Status: -
Join Date: Jun 2016
County: -
Posts: 2
Strange happenings with my 3.0 v6

Hi All - I often read this forum but not had any real issues with my v6 until now.

over the last few months, I have noticed a really bad rubbing whine/creak when the car is on full lock turning left or right, feels mostly left though...I have ignored it a little as I only do very short journeys now and then (less than 3 miles!). When the steering is not on full lock its fine, the steering rack was replaced last year and doesn't sound like a power steering whine (as I can hear that and it sounds normal)

In the last couple of days, I have been on much longer journeys and the car engine actually gets up to the 90 degree temperature, fan kicks in etc. What I have noticed is when the car gets really hot after 1 hour of mixed driving (town/country), the creaking and whining on turning is ever so much present and setting off from a stop really creaks with the steering central as if the car's wheels were made out of 20p pieces or if something was trying to stop the car from moving forward....never happens when the car is cold, always seems when hot. it isn't the engine, that sounds sweet as a nut when clutch is pressed. It mostly comes from near the passenger foot well and sounds drive related.

Car has the GTA clutch, flywheel and Q2 diff and those were fitted about 12,000 miles ago. The suspension is 12 months old (shocks, springs, rubbers etc) and has passed its MOT about 2 months ago with no advisories.

I can't figure it out - anyone experienced such a thing?
alfistimoon is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Nov 2011
Location: United Kingdom
County: Bristol
Posts: 1,393
Images: 2
Sounds like the brakes are sticking on.
spankdanny is offline  
(Post Link) post #3 of 5 Old 30-06-16 Thread Starter
Status: -
Join Date: Jun 2016
County: -
Posts: 2
its not the breaks...the creaking and juddering from stop to go would suggest its something drive related...brakes on would be a constant drag not juddery. Clutch feels fine.

Wondering if it could be the transmission end of the driveshaft....would these be affected by heat?
alfistimoon is offline  
Status: -
AO Silver Member
Join Date: Apr 2008
Location: New Zealand
County: -
Posts: 2,240
So if you're sure it's not the brakes (easy to check, get it hot, jack it up, and see if all 4 wheels spin freely) your next check should probably be the gearbox oil level.
sprint_veloce is offline  
Status: -
AO Member
Join Date: Sep 2015
County: -
Posts: 38
I presume you have checked the CV joints. Have you looked at the intermediate bearing on the O/s drive shaft ?
Alfafrolics is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

happenings , strange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome