Crankshaft Pulse Sensor - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By spankdanny
  • 1 Post By pkr
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 13-06-16 Thread Starter
Status: -
Join Date: Aug 2009
Location: United Kingdom
County: -
Posts: 2

Member car:


Not Happy Crankshaft Pulse Sensor

Hi Guys

I have a dead Speedo in my 1996 Spider.
My mechanic has checked the cables as much as possible and removed the cluster and checked the connections.
Does anyone have a picture of the location for this item.
I spoke to the Alfa Workshop they suggested as its an early model the sensor would be located at the diff - its not and cannot see any connection at the ABS Module. ABS is working fine at the mo.
Any help greatly appreciated.

dereksimpson65 is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Nov 2011
Location: United Kingdom
County: Bristol
Posts: 1,395
Images: 2
The speedo is driven by a sensor on top of the gearbox near the gear change mechanism
dereksimpson65 likes this.
spankdanny is offline  
Status: Planning the next project ...
AO Silver Member
Join Date: May 2007
Location: United Kingdom
County: Bedfordshire
Posts: 3,953
Originally Posted by dereksimpson65 View Post
I spoke to the Alfa Workshop they suggested as its an early model the sensor would be located at the diff
Alfa Workshop is correct. The pulse generator is on the diff.

Unfortunately I don't have a photo of it, but it is there. Your car definitely does not take the signal from the ABS unit.

I found these pics for you ( I'm assuming your car is a TS being a 1996 Spider ) -
Speedometer Doesn't Work Error 64 - Alfa Romeo 145 - 146 Forum
dereksimpson65 likes this.
pkr is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

crankshaft , pulse , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome