Front Fog Light Does Not Work ('98) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 16-12-07 Thread Starter
Status: -
AO Member
Join Date: Oct 2007
Posts: 29

Member car:

GTV '98

Front Fog Light Does Not Work ('98)

Its Me again, trying to fix my GTV to some decent state

My front fog light does not work, to that extent that i do not even hear the clang from the relay. So I'm guessing the relay is busted. But, You guessed it, I do not know where it is.
Please help me find it...

Subquestion: Workshop manuals have this kind of info or not?

Thanks a lot!
milika is offline  
Sponsored Links
Status: -
AO Member
Join Date: Dec 2006
Location: United Kingdom
County: West Yorkshire
Posts: 276
Re: Front Fog Light Does Not Work ('98)

According to the manual it's relay I17 which is in the main fusebox above you're knee.

The diagram shows it as the top right hand relay. however on my car all the fuses/relays are in a completely different places to how the workshop manual shows them.
indiekid is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fog , front , light , work

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome