eractic revs at idle has returned - just a bit - any ideas - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 18-11-07 Thread Starter
Status: -
AO Member
Join Date: Jan 2006
Location: Dublin, Ireland
Posts: 177

Member car:

GTV 2.0 TS Lusso

eractic revs at idle has returned - just a bit - any ideas

I got the air flow meter done and it has made a big difference but still at times, especially when the engine is hot it is dropping revs at idle. This seems to happen towards the end of my 7 mile but 1 hour commute from work where mostly im just sitting in traffic and crawling along. The air flow meter has made the car much better to drive especially at low speeds in low gears so I have to assume the one that was replaced wasnt in good condition but problem of revs dropping at idle hasnt totally gone so something else must be faulty also. Any ideas greatly received?
jessdelahunt is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

bit , eractic , ideas , idle , returned , revs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome