Temperature Sensor Fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 11-01-16 Thread Starter
Status: -
Join Date: Feb 2014
Location: United Kingdom
County: Cheshire
Posts: 3

Member car:

alfa GTV 2.0

Temperature Sensor Fault

Can anyone advise on a 2002 GTV what other fault could cause the Temperature sensor fault to keep happening. Replaced 3 of them all genuine Alfa ones. Fans kick in whenever they feel like and Engine Management light comes on. Goes off when it feels like it too.
jaynep is offline  
Sponsored Links
Status: more house renovations!
AO Silver Member
alfapash's Avatar
Join Date: Aug 2010
Location: United Kingdom
County: Hertfordshire
Posts: 2,205
Maybe it's not the sensor, it could be a thermostat fault and could need replacing. It would seem unlikely that 3 new sensors would be the cause. As for the fan check the connections and the resistor.
Exactly what is happening?
alfapash is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fault , sensor , temperature

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome