Fog Lamp again sorry.... -_-' relay I17 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-01-16 Thread Starter
Status: -
llm3000's Avatar
Join Date: Mar 2012
Location: Hong Kong
County: Central and Western Hong Kong Island
Posts: 1
Fog Lamp again sorry.... -_-' relay I17

Hi all, greeting! A new Alfa GTV 3.0 V6 RHD (MY2001) owner here.

I’ve been trying to fix my fog light as it is not turning on and neither do the light on Dash board, it is off after pressing the button. I googled and looked thru most of the old threads and found some clues and downloaded the repair manual. However there are still something I could not sort out.

I checked the F16 Fuse which is working fine. And from the repair manual, I know that the relay for the Phase 2 GTV is numbered I17 and it is 20A black base. It said that the relay is “on the auxiliary bracket outside the main fuse box”. I can't find that specific bracket with the relay but I only found 3 other relays which are 50A and all black based closer to the driver’s knee direction.

Also knowing that the earth G53a could be one of the reason from previous threads, can someone point me to where this earthing is located? Is it inside the black plastic cover near the head light?

Does anyone know where can I download a pdf owner handbook of the GTV? (not the repair manual). Seems like there are some pages which would show these relay location better than the repair manual.

*My rear fog guard are ok, both the light on the dash and actual lights could be turned on.

llm3000 is offline  
Sponsored Links
Status: Spider on the road again after winter hibernation
Club Member
Membro Medio
Henrik_45's Avatar
Join Date: Jan 2013
Location: Denmark
County: Aalborg
Posts: 450
As the light in the dashboard don't turn on it must be related to the relay I17.
So either this relay is broken or it don't engage when you push the button.

Have you tried to engaged the fog light with the engine is running to hear if the relay is clicking?
The relay should be located on a bracket near the fuse box.

Have you tried to check fuse F4. This will be the fuse used in cars after October 2000
Henrik_45 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fog , i17 , lamp , relay

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome