Hose clips??? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By Alfa git
  • 1 Post By Alfa git
  • 1 Post By alfame2000
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 12-09-15 Thread Starter
Status: sailing to retirement.
AO Silver Member
Headgasket14's Avatar
Join Date: Aug 2014
Location: United Kingdom
County: Suffolk
Posts: 1,939
Hmmm Hose clips???

My spider has passed it's MOT again with only a tyre wear advisory, so now I am going change the thermostat as I think it's failing/failed. I know how to do it, soaked everything in plus gas to soak in for a few days and have also read the how to threads to ensure I don't miss a trick. HOWEVER, I cannot find out how many of you who have done this job, remove those flamin horrible clips holding the hoses on.....Many say "removed the hoses" or "there is a special tool but don't know where to get one"....so how do most of you remove those clips please? (I'll be jubilee clipping back up).
Headgasket14 is offline  
Sponsored Links
Alfa git
Status: - Update
Posts: n/a
I've recently taken one off, just put a flat screw driver in the gap where it joins and prized it off.
Headgasket14 likes this.
Alfa git
Status: - Update
Posts: n/a
P.s. Damaging it in the process, but as you've said your not re using.
Headgasket14 likes this.
Status: -
AO Member
Join Date: Dec 2013
Location: United Kingdom
County: Tyne and Wear
Posts: 71
Originally Posted by Headgasket14 View Post
....so how do most of you remove those clips please? (I'll be jubilee clipping back up).
use Clic-R pliers, they are widely availble eg:-
swivel headed get into the tight places, are available fixed for half the money.

with correct use of the right plier, the Alfa clic-R clips are vastly better than jubilee, the latter are likely to damage your expensive hoses over time and should be avoided IMHO.
The 'other' type of hose clip have to be cut off, best replaced with Mikalor Supra hose clips.
Headgasket14 likes this.

Last edited by alfame2000; 12-09-15 at 23:02. Reason: 'Supra'
alfame2000 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

clips , hose

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome