electric boot release - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 05-09-07 Thread Starter
Status: -
Join Date: Aug 2007
Posts: 9

Member car:


electric boot release

On purchasing my 3 litre gtv about 4 months ago i seem to have quite a few faults with it (welcome to been an Alfa owner eh). i have already enquired about faulty wipers but it also releases the elecrtic boot release every 30 seconds. i have since dis connected it but would like it to work correctly, any ideas?
stuart grocock is offline  
Sponsored Links
Status: pretty good actually...!
AO Member
Cibo's Avatar
Join Date: May 2007
Location: Ireland
Posts: 695

Member car:

916 Spider

Re: electric boot release

I had this exact problem with my spider about two months ago, tried to get the switch out of the glovebox to have a poke at it but had to give up eventually (I am a klutz, and can cause amazing levels of destruction armed only with a screwdriver...).

Had to get a new switch fitted in a stealership....
Cibo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

boot , electric , release

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome