GTV power steering problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 18-07-15 Thread Starter
Status: -
Join Date: Jul 2015
County: -
Posts: 2
GTV power steering problem

Hi guys,

I'm new here, but see many post about power steering issues. Someone might can help me a bit with tips/advice.

I have a gtv and my power steering was working well..
then I did a complete motor rebuild and many other parts replaced (starter, generator..) kind of a big service.
At the end, when everything was back and worked the power steering was gone.. but only when the rpm is lower then 2500 rpm.. above this, it all works.

No noise, no sign of any error, no leaks and the pump also looks normal. As I checked mostly 2 things could causing this, 1. pump or 2. steering rack. Since both are quite expensive, I want to make sure I replace the right one at first.

Could anyone help how to double check easily if it's pump or rack or might be other issue (fluid?? btw, I have red fluid in it)


AttilaTheHun is offline  
Sponsored Links
Status: #keepFightingMichael
AO Gold Member
EauRouge's Avatar
Join Date: Jun 2009
Location: Suriname
County: Brokopondo
Posts: 7,568
Images: 12
Did you properly bleed the system when you changed fluid? also how did you bleed pump and rack when you emptied system?
EauRouge is offline  
(Post Link) post #3 of 4 Old 19-07-15 Thread Starter
Status: -
Join Date: Jul 2015
County: -
Posts: 2
Thanks for the quick reply!

I have to check this with my mechanic, it was not actually me who did all the work.. :P

Would help if you can point me what would be the proper way and what if it was not properly done. Could this cause the low-rpm issue?
Thanks a lot!
AttilaTheHun is offline  
Status: -
AO Silver Member
Join Date: Nov 2011
Location: United Kingdom
County: Bristol
Posts: 1,393
Images: 2
Bleeding the system just entails turning the steering from lock to lock a few times with the engine running and checking the fluid levels. Check the tension on the belt too.
spankdanny is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

gtv , power , problem , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome