Go! pedal trouble - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-08-07 Thread Starter
Status: leaving
AO Silver Member
neilied's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Cardiff
Posts: 1,055
Help Go! pedal trouble

hi guys.... help

since owning the car dec 05 the throttle pedal has been quite stiff. seems to be an easy bit of travel but then to hit the floor it needed a bit of shove. took the car to have the matrix valve replaced. when i picked up the car it was A1 almost caught me out as i shot off from the side of the road. anyhow 3 wks later and its reverted back to times of old and now even worse. when i floor it i keep full pressure and can feel and hear that adjustable bolt hit the floor then i feel a bit of movement and i can push further again hitting the floor and so on 2-3 more times. weird??? also when initialy pumping the pedal to the floor the travel feels only a few inches?? this is a p1 car so maybe cable probs but there according to eper is 2 cables.... help please????

ok guys advice please... is it a case of renewing the throttle cable. the eper show 2 cables?? or is it something more sinister
neilied is offline  
Sponsored Links
Status: -
AO Member
Spiderme's Avatar
Join Date: Jun 2007
Location: Australia
Posts: 245
Re: Go! pedal trouble

Hey there

in this forum do a search and there is a thread on stiff gas pedals. Mine does what yours does but not frequently more like once every 2 months, it seems to be a common problem.

When you find the thread (soz don't know how to link it) there is something connecting to the gas pedal which you can adjust and or lubricate....i lubricated mine and the problem was fixed.

Good luck

Cheers Josh
Spiderme is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

pedal , trouble

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome