turn indicator problem... need help =) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 17-08-07 Thread Starter
Status: -
AO Member
kenogre's Avatar
Join Date: Jun 2006
Location: Manila, Philippines
Posts: 334
Images: 12
turn indicator problem... need help =)

hello.. ...the left turning lights and hazard lights of my gtv work fine but the right turning lights won't work(they won't function but bulbs work fine)... must be a relay/fuse problem... where is the relay/fuse for the right turning indicators located? below the dashboard or in the engine compartment? what part number am i looking at?
kenogre is offline  
Sponsored Links
Status: -
AO Silver Member
euroboy's Avatar
Join Date: Sep 2006
Location: Netherlands
County: -
Posts: 2,877
Images: 52
Re: turn indicator problem... need help =)

Check the actual stalk on the steering column is ok. I had a similar(ish) problem last year and it turned out that the casing on the steering column was cracked, this allowed the stalk to move around and therefore the contacts couldnt 'touch'each other.

I bodged a repair with superglue and elastic bands!!! and as has been ok since.
euroboy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

indicator , problem , turn

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome