Concern? Burnt Fan Resistor Contacts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-06-15 Thread Starter
Status: missing my GTA
AO Silver Member
Join Date: Jan 2009
Location: United Kingdom
County: Lincolnshire
Posts: 1,589
Concern? Burnt Fan Resistor Contacts

Afternoon all,

Running through the list of things to do on my Phase 1 that I'm slowly bringing back to life and being what it is, everywhere you look there is a new thing to fix!

Was looking at reasons why my aircon may not be working and tracing wires back when I spotted that the right hand side wire on both fan speed resistors was out of the housing / casing and looking very black and burnt.

Although the ceramic has come off the resistors they don't actually look that bad, though I've not tested on a multimeter as yet.

Any idea what kind of readings / values I should see from them and if I should be concerned that both wires were out?

Previous Alfas:
1999 156 1.8TS Sport Pack 3
2001 166 3.0 V6 24V Super
2003 156 GTA 3.2 V6 24V
2005 156 1.9 JTDM-Jet Sport
2008 159 1.9 JTDM Lusso

Current Alfas:
1997 GTV 2.0TS Lusso
2001 147 1.6TS Lusso
Artermis is offline  
Sponsored Links
Status: Spinning like a cat
AO Member
redtop_68's Avatar
Join Date: Sep 2011
Location: Sweden
County: Stockholm
Posts: 515

Member car:


Originally Posted by Artermis View Post
Any idea what kind of readings / values I should see from them and if I should be concerned that both wires were out?
They are 0.18. If the connectors are broken you will only get full speed on the fans. They will kick in later, but since full speed works there's no risk of damaging the engine.

If you have the M2.10.4 ECU and do the actuator test in Multiecuscan there seems to be a bug: full and half speed are mixed up.

I replaced the original (expensive) resistors with some I got from Aliexpress for a couple of $. Make sure they can handle 100W.
Some pictures here:
916 GTV 2.0TS - Fix och trix - Club Alfa Romeo Svezia - Forum - Club Alfa Romeo Svezia - Projekt
redtop_68 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

burnt , concern , contacts , fan , resistor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome