ABS speedo stops working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-05-15 Thread Starter
Status: -
AO Member
cosmicjac's Avatar
Join Date: May 2014
Location: United Kingdom
County: West Yorkshire
Posts: 12

Member car:

mito and v6 GTV

ABS speedo stops working


I know this is an old problem, much reported before...but there doesn't seem to be a definite solution.

To recap on my issue... GTV V6 ph2, 1999. Drive from cold, after approx 5 miles, ABS and "!" brake lights come on and the speedo stops. Once the engine cools, then it works again and the process repeats.

My indie experts are a bit mystified, just wondered what it can be. Don't want to waste time/money on ebay abs pumps, replace ecu, wheel sensors if its something like a bad earth.

Any help would be appreciated.

cosmicjac is offline  
Sponsored Links
Status: -
AO Member
gazc's Avatar
Join Date: May 2009
Location: United Kingdom
County: Gloucestershire
Posts: 355
When it happens have you checked if anything else cuts out - it could be a relay, on the 97 model year it's rear fog lights and electric windows on the same relay (sorry I've only got the schematics printed for that model but there is a link somewhere to the full searchable workshop manual)..
If not then I think I'd be opening the ABS unit and checking for bad solder joints.
gazc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

abs , speedo , stops , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome