Going nowhere! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 24-05-15 Thread Starter
Status: -
AO Member
Join Date: Sep 2010
Location: United Kingdom
County: Lincolnshire
Posts: 26

Member car:

GTV V6 24Valve

Going nowhere!

OK, so I appreciate that I neglect my old GTV more than I should and so today it let me down. Normally it fires on the button but today all the lights are on with a fully charged battery but no starter engagement or sign of life on turning the key. I haven't clubbed the starter yet but suspect it's neglect that's come home to roost. Too many cars to play with and now missing that V6.:depressed
Ravioli is offline  
Sponsored Links
Status: sailing to retirement.
AO Silver Member
Headgasket14's Avatar
Join Date: Aug 2014
Location: United Kingdom
County: Suffolk
Posts: 1,939
Might be a dodgy earth etc. Are the battery terminals tight on the battery? Maybe enough to show the lights, but not enough to do much more. I reckon it could well be an earthing problem somewhere.
Headgasket14 is offline  
Status: Summer's here - roof is down!
AO Member
Cluffstarr's Avatar
Join Date: Jan 2006
Location: United Kingdom
County: Somerset
Posts: 931
Does the Key Code light go out? If not, could be that the Halo ring is not picking up the key code from the key...
Cluffstarr is offline  
Status: nearly there
AO Silver Member
Mr_Caine's Avatar
Join Date: Mar 2002
Location: United Kingdom
County: Surrey
Posts: 3,185
Images: 56
I was going to suggest the key code, my old v6 was a bit temperamental sometimes and did just the same.
Mr_Caine is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome