916 Spider Roof Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 08-04-15 Thread Starter
Status: -
AO Member
Join Date: Feb 2013
Location: United Kingdom
County: Staffordshire
Posts: 13

Member car:


916 Spider Roof Problem

I have a 2001 916 spider and roof was working perfectly OK on Monday - came to put it down today & starts OK until the rear roof has lifted and the metal stowage cover should raise up - it doesn't. Anyone have any ideas?
Dgmalpy is offline  
Sponsored Links
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
Six or seven posts down from yours is a post from Paul:

Originally Posted by PaulR View Post
Operate it manually using the buttons below the rear parcel shelf on the drivers side. Using the manual procedure there is no danger of it getting stuck.

After a couple of times try again using the automatic buttons.

I find that mine will stop working for no apparent reason then, all of a sudden, just start working again. It happened today - for the last two weeks I had to do it manually but today it opened and closed on the switch.

Might be worth checking the fluid levels?

P.S. - if you are unsure of the manual procedure (sorry if you are) it is this-

Behind the drivers seat underneath the parcel shelf and to the left of the rear speaker as you look at it, you will see a small plastic cover. Remove this and you will then see two switches. Turn the ignition on (handbrake on). Release the two manual catches on the windscreen. Press the switch mentioned above on your left as you look at it and it will release the rear screen. By hand lift the rear screen up until it clears the the cover (you will have to make sure the screen folds evenly). Then press the other switch and the cover will release - lift the cover back by hand (you may have to turn the ignition off). You will then be able to tip the roof back into the compartment. Lower the cover by hand then ignition on and press the switch to lock the cover. To manually raise it just do what I have said in reverse order!

It sounds complicated but once you have done it is quite easy - just remember if at any point you cannot move the rear cover or roof by hand just switch off the ignition- it takes the pressure off the hydraulics - and the ignition only needs to be on to activate the switches.
Clive added:

Originally Posted by CGTVs View Post
Is your hood cover opening?

When pressing the appropriate emergency button behind the seat you should hear it click to release the cover, if it doesn't then it's the motor stuck. If not give the electric motor, in the centre of the rear cubby hole, a 'gentle' tap with a hammer while pressing the switch..../...

There's also a search function somewhere on AO (oh here it is ), but I could understand how the multitude of Spider roof related posts might give you the creeps....
Al Faromeo is offline  
Status: Life is good atm. I do not take that for granted.
Global Mod Team
PaulR's Avatar
Join Date: Mar 2005
Location: United Kingdom
County: Suffolk
Posts: 21,473
This is a common problem.

Have a look here:-


In particular the clout with a mallet may help.
PaulR is offline  
(Post Link) post #4 of 4 Old 08-04-15 Thread Starter
Status: -
AO Member
Join Date: Feb 2013
Location: United Kingdom
County: Staffordshire
Posts: 13

Member car:


Thanks both fort quick reply - will give it a go topmorrow
Thanks again
Dgmalpy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

916 , problem , roof , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome