Mot failure ! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-03-15 Thread Starter
Status: -
AO Member
Join Date: Feb 2014
Location: United Kingdom
County: South Yorkshire
Posts: 17

Member car:


Mot failure !

Hi my 02 reg spider has just failed it's mot on several relatively minor things, inc front brake hoses, handbrake etc but what's the best cause of action to rectify the following?

N/S & O/S,
1) rear suspension arm has excessive play in a ball joint
2) rear outer (rose bush) suspension arm has excessive play in a pin/bush
3) rear inner (rose bush) suspension arm has excessive play in a pin/bush
I'm not sure which bits of the rear suspension they relate to, can I just replace the bushes, should I use the powerflex type ?
johntom is offline  
Sponsored Links
Status: #keepFightingMichael
AO Gold Member
EauRouge's Avatar
Join Date: Jun 2009
Location: Suriname
County: Brokopondo
Posts: 7,568
Images: 12
The rose bush are original fit on the springpans. If you remove rear wheel and look at the big lower suspension arm that the spring rests in that is the arm you need to remove. The best cure would be have it polybushed.

The ball joint is up top and left (Drivers side) ie: towards rear of car. This is bolted to upper wishbone via two bolts and the balljoint is one nut. This is easy diy and part is approx £30.

Be careful when replacing rubber brake hoses that you do NOT drain brake fluid and air lock abs unit, otherwise you really will have a nightmare.
Buy a set of rubber hose clamps and clamp hose before removing caliper 1st. Screw new hose into caliper before attempting to release hose from copper brake line. (Spray union liberally with +Gas) if you manage to release rubber hose from copper line without snapping copper line, you have done good. Quickly release clamp and as quick as you can wind on new rubber hose and bleed corner. Repeat at other side/s.

Last edited by EauRouge; 20-03-15 at 23:34.
EauRouge is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

failure , mot

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome