GTV Immobiliser Code Issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 18-06-07 Thread Starter
Status: -
AO Member
Join Date: Mar 2007
Location: Llanelli
Posts: 116
GTV Immobiliser Code Issue


I have a 1998 GTV V6.

My immobiliser has engaged at the moment where it will only let the car run for 8 seconds or so before shutting the car down. I have tried a local garage regarding getting it plugged in to a computer and reset and he told be it was highly likely I had the incorrect code.

Is there anyway of getting the immobiliser code confirmed ? I have little knowledge so not sure what is involved. Rather not take it to local Alfa Dealer as it is 15 miles away and they charge over £100 an hour.


Jeffrz is offline  
Sponsored Links
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
Re: GTV Immobiliser Code Issue

How do you know the immobilisor is engaged? I thought Immobilisors completely prevented the car from starting.. not just for 8 seconds.

How long do you have to leave it before it starts again? Or does it run for just 8 seconds at a time and then you have to re-start it?

If the beast starts-stops-starts-stops then I'd guess there is an ECU fault as it must be running through some sort of startup cycle and hitting a wall.

On the other hand if the car runs and then fizzles out and won't start immediately then it could be something mechanical like and obstructed fuel line etc.

A specialist should have a look at the ECU first.. that might point you at the next thing to look at.

Ralf S.

No bullets for Chaingun..
Ralf S. is offline  
Status: -
AO Silver Member
Wrenched's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: Warwickshire
Posts: 1,807

Member car:

GTV 24v

Re: GTV Immobiliser Code Issue

Is eight seconds too long for it to be a fuel pump circuit problem? What do you mean by immobilser 'engaged'? If the light is on you may have two problems that aren't related. I know I just love looking for the complicated/unlikely!
Wrenched is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

code , gtv , immobiliser , issue

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome