gtv - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 16-01-15 Thread Starter
Status: -
AO Member
Join Date: Oct 2014
Location: United Kingdom
County: West Midlands
Posts: 17

Member car:

alfa gtv


HI can anyone help i cannot get my heaters to work i have changed everything from the fan motor / resister / control switces / fusebox and it still wont work thanks titan gtv
titan gtv is offline  
Sponsored Links
Status: I have an Italian car problem
AO Silver Member
jurdy1's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: Kent
Posts: 1,193
Images: 20
Thermostat and switch? When you drive your car (normal road use) does the temp guage not move very far? If so, it is more than likely the above.
jurdy1 is offline  
Status: Planning the next project ...
AO Silver Member
Join Date: May 2007
Location: United Kingdom
County: Bedfordshire
Posts: 3,953
Phase 1 or 2/3?

If it's a phase 1, it could be a failed bowden cable or if phase 2/3 a failed actuator motor.
pkr is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome