Spider abs light on,and no lights - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-01-15 Thread Starter
Status: -
Join Date: Jan 2015
Location: I would rather not say
County: -
Posts: 1

Member car:


Spider abs light on,and no lights

Hi, I have a spider 98 model with no lights working,abs light on and no widows working. I have read about this i35 relay. I have no power to fuses for headlamps, is there any wiring diagrams available? Many thanks

Koolgang1 is offline  
Sponsored Links
Status: Spider on the road again after winter hibernation
Club Member
Membro Medio
Henrik_45's Avatar
Join Date: Jan 2013
Location: Denmark
County: Aalborg
Posts: 450
I would say you should check fuse F15.
This fuse is common for lights, power windows and Service ECU
Attached Images
File Type: jpg Head_Light_Wiring_PH2.jpg (71.0 KB, 2 views)
File Type: jpg Power_Window_PH2_98.jpg (88.2 KB, 2 views)
Henrik_45 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

abs , light , lights , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome