'98 spider indicators - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 07-05-07 Thread Starter
Status: -
Join Date: Apr 2007
Posts: 6

Member car:

'98 Spider

'98 spider indicators

just bought a spider and recently the indicators are starting to play up.

they are flashing really quick on the right side, which i know now means one of the bulbs have gone, but at the moment the three bulbs on the right are taking it in turns to stop working.

i was wondering if anyone else has this problem and how to fix it.
stuart11178 is offline  
Sponsored Links
Status: -
AO Member
earthman's Avatar
Join Date: Aug 2003
Location: london
Posts: 629
Re: '98 spider indicators

not had the problem myself but maybe it's a bad earth? check the earthing points on all three.
earthman is offline  
Status: -
AO Silver Member
DevonDan's Avatar
Join Date: May 2007
Location: Exeter
Posts: 1,532
Re: '98 spider indicators

simple things first ... also scrape clean the connectors on the bulbs, assuming they are "normal" bulbs .... I havent had to take miine out yet!

DevonDan is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

indicators , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome