Rear hub play ???? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-10-14 Thread Starter
Status: -
AO Member
NFN's Avatar
Join Date: Jul 2008
Location: Tamworth
Posts: 66

Member car:

GTV 3.0 V6 X reg

Rear hub play ????

so had a tyre fitted today and took chance to move wheel to check bearing play and there was some very slight play take it these have hub bearing so hub nut should be tight

There should be no play at all right and solid ?

Also mine is an X-reg v6 would that be the spline hub bearing ?
NFN is offline  
Sponsored Links
Status: Suspension re-build complete, what next?
AO Member
GTV_Blue's Avatar
Join Date: Oct 2012
Location: United Kingdom
County: Leicestershire
Posts: 920
Images: 9

Member car:

GTV 3.0 V6 24v

Yes, hub should not move; the torque on the hub nut is about 270Nm if I remember. My "big" torque wrench only went up to 210Nm so I gave it another 1/4 turn.
GTV_Blue is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

hub , play , rear

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome