MOT Emissions Failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-03-07 Thread Starter
Status: -
AO Member
Lardy1664's Avatar
Join Date: Jan 2007
Location: Farnborough
Posts: 41
Hmmm MOT Emissions Failure

Well just thought I'd share this with a few folks that might gleen a little info from it.

Took the '04 spider for it's first MOT last week not expecting anything to be wrong although it did have the EOBD light on which I was waiting to get looked at .
Sitting in the waiting room listening to the revvvvving of the engine I began to think "whats all this then" . Only to be told that it had failed on high exhaust emissions. So a call to SGT's in Taplow , booked me in for Wed this week to look at the EOBD light and the emissions fault.

After about 30 mins at SGT's they came out saying there was a fault with 2 of the Lambda sensors and it would take about 2 hours to fix. Thinking of the 80 per hour labour charge I was about to make for the credit card when they stated it was a known fault and there was a service bulletin detaling the job required and it would be covered under the warranty result especially as the warranty runs out in 3 days.

They said they had to solder the connections to the sensors and all would be fine . Not sure of the location of the sensors but thought this might come in handy for someone.

So glad I took the car in for the MOT a week before the first reg date cos the warranty ran out 3 days after SGT's carried out the work.

I did ask them of any other items that they know about , they listed a few , the connections to the seat sensor gets dislodged from moving the seats back n forth , air bag sensors in the sides of the boot sometimes get knocked if you try to fit in large pieces of luggage ( takes about 2 hours to get to connections ) and some roof leaks .
So with no warranty left now I hope these items don't crop up or I'll just have to them myself

p.s. I did pass the retest btw
Lardy1664 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: MOT Emissions Failure

glad to hear you passed


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

emissions , failure , mot

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome