have I found a drop in Spider 916 replacement sub woofer ? - Page 4 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 2Likes
Reply
 
Thread Tools
Status: Busy busy busy!
Club Member
Membro Premio
 
Pud237's Avatar
 
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 42,285
I'm fitting the Pyle speaker into a sub-box and putting it in the track slag along with a pair of box-mounted 6x9s and an old JVC headunit. There is currently no sound system or loom so will have to make one. It'll be nice to have sound music again for long journeys but I'll have to make everything quick-release for trackdays.
Attached Images
File Type: jpg 009.jpg (122.5 KB, 32 views)
Pud237 is offline  
Sponsored Links
Advertisement
 
Status: Alfa 4C on my wanted list
AO Member
 
stratosmgt's Avatar
 
Join Date: Dec 2011
Location: United Kingdom
County: North Yorkshire
Posts: 378
Images: 30
Just logged into my Amazon account,
used this link kindly provided on this thread :Amazon.com : Pyle PLPW6D 6-Inch 600 Watt Dual 4 Ohm Subwoofer : Vehicle Subwoofer Systems : Car Electronics....................
and ordered 2 for a grand total of 34.77 including delivery, one for me and one for my old man. At this rate every Spider in the UK will have one fitted.
stratosmgt is offline  
Status: meh
AO Member
 
Donalh's Avatar
 
Join Date: Nov 2007
Location: Ireland
County: Meath
Posts: 301
Images: 6
Garage
Hi Guys
I jumped onto the Pyle speaker wagon. Ordered it on Sunday night and it was on my desk in work on Thursday morning, total cost 21.34. Fitted it this afternoon, total time 20 minutes. Big improvement on the original, weighs probably twice that of the original.
So now thanks to here and spending 119.25, I've greatly improved the audio in the car. It now consists of they following:

Replacement Head Unit
Replacement Front Speakers
Replacement Rear Speaker

Great improvement on the original setup. One question I have is on the polarity of the wiring. I've kept it consistent by going solid colour to positive on all speakers but I not 100% convinced it's correct. Can anybody help?

Donal
Donalh is offline  
 
(Post Link) post #79 of 126 Old 22-11-14 Thread Starter
Status: -
AO Member
 
Join Date: Aug 2014
County: -
Posts: 102

Member car:

alfa spider

Guys,

I am so happy I discovered this speaker and thanks to everyone enjoying it and the advice I received when asking would it fit before i decided to buy.

Happy Christmas everyone!

leeoh
leeoh is offline  
Status: Spider being painted!
AO Member
 
Vansflyer's Avatar
 
Join Date: Jun 2013
Location: United Kingdom
County: West Midlands
Posts: 479
Got around to fitting one today in the V6, pleasantly surprised :-) still got two spare if anyone wants one and can't be bothered to wait... 25 each inc delivery.
Vansflyer is offline  
Status: 00v00
AO Silver Member
 
Join Date: Nov 2007
Location: South Africa
County: Johannesburg
Posts: 1,936
I've ordered mine too. Looking forward to getting it in and working.
alastpa is offline  
Status: Finally got a Spider :-D
AO Silver Member
 
Join Date: Jan 2003
Location: Portugal
County: Sesimbra
Posts: 4,077
Images: 6
Garage
I've ordered mine and fitted it... big improvement!!! all for 29,90 delivered at home :-D

All the best

Srgio
montreal is offline  
Status: Long live the nice weather
AO Silver Member
 
GT Paddy's Avatar
 
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 1,132
Fitted mine today. Massive improvement especially given the price
GT Paddy is offline  
Status: more house renovations!
AO Silver Member
 
alfapash's Avatar
 
Join Date: Aug 2010
Location: United Kingdom
County: Hertfordshire
Posts: 2,235
My Pyle speaker arrived from the states yesterday. It has 4 spade connectors, 2 on each side, from memory there are only two wires that connect to the old OE speakers, which ones do I use and do I need to make any alteration to the wiring?
alfapash is offline  
Status: -
AO Silver Member
 
euroboy's Avatar
 
Join Date: Sep 2006
Location: Netherlands
County: -
Posts: 2,877
Images: 52
Garage
Quote:
Originally Posted by alfapash View Post
My Pyle speaker arrived from the states yesterday. It has 4 spade connectors, 2 on each side, from memory there are only two wires that connect to the old OE speakers, which ones do I use and do I need to make any alteration to the wiring?
There should be 4 wires - its a dual input speaker.
euroboy is offline  
Status: more house renovations!
AO Silver Member
 
alfapash's Avatar
 
Join Date: Aug 2010
Location: United Kingdom
County: Hertfordshire
Posts: 2,235
Thanks euroboy, in that case does it matter which wire goes where.
alfapash is offline  
Status: -
AO Silver Member
 
euroboy's Avatar
 
Join Date: Sep 2006
Location: Netherlands
County: -
Posts: 2,877
Images: 52
Garage
Yes, I believe so.... Otherwise the speaker will be out of phase.

Can't remember which way around they should be though, sorry.
euroboy is offline  
Status: Alfa V6 - the bestsounding V6
AO Member
 
markymarkspider's Avatar
 
Join Date: Sep 2009
Location: United Kingdom
County: Vale of Glamorgan
Posts: 602
Images: 22
I had to do a bit of experimenting to get mine "phased" correctly

(in other words I just guessed and then swapped them around when it didn't sound right)
markymarkspider is offline  
Status: -
AO Silver Member
 
euroboy's Avatar
 
Join Date: Sep 2006
Location: Netherlands
County: -
Posts: 2,877
Images: 52
Garage
Quote:
Originally Posted by markymarkspider View Post
I had to do a bit of experimenting to get mine "phased" correctly

(in other words I just guessed and then swapped them around when it didn't sound right)
I did that too
euroboy is offline  
Status: Spider being painted!
AO Member
 
Vansflyer's Avatar
 
Join Date: Jun 2013
Location: United Kingdom
County: West Midlands
Posts: 479
Used one of my spare Pyle speakers today as a replacement for a 18 year old Kenwood Subwoofer unit that had perished ... 18 years... tsk tsk. Cut a bit of wood up to build the space between the housing and the smaller Pyle unit and good to go... Can confirm when amped the little speaker has quite a kick... The Cup has bass back...One speaker left so off to build a compact sub for the V6 Spider ;-)
Vansflyer is offline  
Status: -
AO Member
 
Join Date: Jul 2014
Location: Finland
County: -
Posts: 53

Member car:

Spider -98

Quote:
Originally Posted by Vansflyer View Post
Used one of my spare Pyle speakers today as a replacement for a 18 year old Kenwood Subwoofer unit that had perished ... 18 years... tsk tsk. Cut a bit of wood up to build the space between the housing and the smaller Pyle unit and good to go... Can confirm when amped the little speaker has quite a kick... The Cup has bass back...One speaker left so off to build a compact sub for the V6 Spider ;-)
Just found this topic and maybe Im late
Do you still have an extra speaker?
Im interested.
Amazon shipping to Finland is 45, so I feel a bit stupid to pay 3 times the value on shipping....
FinSpider is offline  
Status: Spider being painted!
AO Member
 
Vansflyer's Avatar
 
Join Date: Jun 2013
Location: United Kingdom
County: West Midlands
Posts: 479
No problem sharing, PM me your address and I'll get a cost on shipping.
Cheers
Vansflyer is offline  
Status: -
AO Member
 
Join Date: Jul 2014
Location: Finland
County: -
Posts: 53

Member car:

Spider -98

Quote:
Originally Posted by Vansflyer View Post
No problem sharing, PM me your address and I'll get a cost on shipping.
Cheers
Pm is sent.

Thanks.
FinSpider is offline  
Status: -
AO Member
 
Join Date: Jul 2014
Location: Finland
County: -
Posts: 53

Member car:

Spider -98

Quote:
Originally Posted by Vansflyer View Post
No problem sharing, PM me your address and I'll get a cost on shipping.
Cheers
Thanks for your efforts Mate, but I went the ebay route instead.
Pretty much 40 delivered and they allready sent it!
2 hours after purchase I got an email with tracking number, now that is impressive!
FinSpider is offline  
Status: Spider being painted!
AO Member
 
Vansflyer's Avatar
 
Join Date: Jun 2013
Location: United Kingdom
County: West Midlands
Posts: 479
No worries.
Vansflyer is offline  
Status: alive n kicking!
AO Member
 
rickie_20's Avatar
 
Join Date: Feb 2010
Location: United Kingdom
County: West Midlands
Posts: 82
Spare

Quote:
Originally Posted by Vansflyer View Post
No worries.

@vans, how much do you want for your spare one?

After reading thread the other night ordered \ back ordered one from Amazon usa, not convinced it will ever arrive tho'

Pm me please mate
rickie_20 is offline  
Status: Spider being painted!
AO Member
 
Vansflyer's Avatar
 
Join Date: Jun 2013
Location: United Kingdom
County: West Midlands
Posts: 479
Sub

Rather than a Pm in case this gets asked again.: lol:

Hi, 25 for the speaker if you collect from Sutton or + postage at cost. I got stuffed import duty when I ordered mine so it's what it cost me less a bit!
Cheers.

Last edited by Vansflyer; 27-03-15 at 11:26. Reason: Mistake
Vansflyer is offline  
Status: alive n kicking!
AO Member
 
rickie_20's Avatar
 
Join Date: Feb 2010
Location: United Kingdom
County: West Midlands
Posts: 82
Thanks mate, just so happens had an email from Amazon with a delivery date

So looks like it's on its way
rickie_20 is offline  
Status: Spider being painted!
AO Member
 
Vansflyer's Avatar
 
Join Date: Jun 2013
Location: United Kingdom
County: West Midlands
Posts: 479
Not a problem, if no one wants it I am going to build a box for it with an amp and put it in the boot of the Spider V6... if it ever comes back from the paint shop.... A good little speaker with an amp on it ;-)
Vansflyer is offline  
Status: -
AO Member
 
Join Date: Jul 2014
Location: Finland
County: -
Posts: 53

Member car:

Spider -98

Got mine today and just a minute ago got it in its place.
Naturally its better than the old one (daa-a) but Im not convinced yet. Doesnt seem to give much of an umph. Maybe I was waiting for too much.
Also I have a strange feeling that this is not a genuine Pyle, more like some cheap Ch***** copy...

Anyway, its there and some sound comes out of it...


Anyway, is there more than one way to wire this thing?
Lower amount of impedance equals more power, right?

There are these 4 original wires for the original speaker. Thats simple. But can you connect the wires so that it becomes 2 ohm?
That way the "sub" should be more powerful, right?

Also, it might be a good idea to block the higher frequences from the rear with a crossover (Im not sure about the english term)?

Last edited by FinSpider; 09-04-15 at 16:48.
FinSpider is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Tags
916 , drop , found , replacement , spider , woofer

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome