Temperature gauge problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 13-03-07 Thread Starter
Status: -
AO Member
mattyman27's Avatar
Join Date: Jun 2004
Location: Australia
Posts: 15

Member car:


Temperature gauge problem


The temperature gauge on my 2000 Spider used to normally sit below 90deg. These days, after driving for 5 or 10 mins, especially if the car sits idle in traffic, the temperature goes above 90deg, sometimes up to 110deg and doesn't go back below 90.

However, if I turn on the climate control, then the temperature gauge performs normal and does not exceed 90 deg (as I believe it should).

Any ideas? and what should be normal temperature?
mattyman27 is offline  
Sponsored Links
Status: -
chris gtv's Avatar
Join Date: Feb 2007
Posts: 6

Member car:

GTV 2.0 TS Lusso

Re: Temperature gauge problem

I had problems with the temperature of my 2.0 GTV, only mine was running cold. Since fitting a new thermostat she runs at around 75 - 80 degrees after about 10 mins.
chris gtv is offline  
Status: -
AO Silver Member
Wrenched's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: Warwickshire
Posts: 1,807

Member car:

GTV 24v

Re: Temperature gauge problem

Turning on climate control on many cars overrides the thermostatic cooling fan switches to get enough air through the cooling 'pack' to keep the engine cool and operate the A/C. I suggest whatever switch it is that normally controls the cooling fans needs looking at.
Wrenched is offline  
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
Re: Temperature gauge problem

What Wrenched said.

The fan switch isn't working when the temperature goes to 92C. It's supposed to cool you down to 88C.

With a/c on, the fan is running permanently (I think I read) so you don't get the overheating in the first place.

The thermo' switch is a 22mm plug (or similar) bolted into the radiator. It'll have a pair of wires leading to it.

Ralf S.
Ralf S. is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

gauge , problem , temperature

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome