engine noise on my twin spark - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 25-08-14 Thread Starter
Status: baffled
AO Member
 
GTVbub609's Avatar
 
Join Date: Aug 2011
Location: United Kingdom
County: Gloucestershire
Posts: 131
Images: 14
engine noise on my twin spark

Hi folks thought id test the water here and see what people had to say, my GTV has developed a nasty wine it gets higher pitched through the rev range so it sounds like its something attached to the cam belt?

it started a while ago but the car has been stored for a while because I've been saving to get her all done up! the noise doesn't seem to effect performance she still pulls really well in all gears and changes gear smoothly.

I had the cam belt and water pump changed about 15,000 miles ago and the car has only done 72,000.

anybody experienced this them selves or got any ideas?


thanks, Jon
GTVbub609 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Jul 2014
Location: Scotland
County: Falkirk
Posts: 599

Member car:

147

It could be related to the timing belt or it could be the balance belt. Easiest thing to check is it related to the aux belt/alternator/power steering/air con system.

If you can safely get the car up on axle stands, remove the aux belt if the noise disappears then its somewhere on that belt run then you can start checking them individually - it may simply be the aux tensioner thats become noisy
Davffc is offline  
Status: -
Newbie
 
Join Date: Feb 2013
Location: South Africa
County: Western Cape
Posts: 1

Member car:

GTV 2.0 TS

It sounds like the same problem I had not too long ago. My car had been sitting a while and once I started the engine, I heard that noise. It was really unbearable to listen to. It appeared to be related to the aux belt, drove myself insane removing the belt and pulleys numerous times, and testing them seperately but could find nothing wrong. In the end I tried sprinkling the pulleys with baby powder once everything was placed back and it stopped the high pitched whining for quite a while - I kid you not! I carried that bottle of baby powder with me while driving around and dusted the pulleys lightly each time the noise came back and after a couple of times of doing that it completely disappeared.
Persephone916 is offline  
(Post Link) post #4 of 4 Old 29-08-14 Thread Starter
Status: baffled
AO Member
 
GTVbub609's Avatar
 
Join Date: Aug 2011
Location: United Kingdom
County: Gloucestershire
Posts: 131
Images: 14
Well the car had its MOT yesterday which it passed...eventually it took 3 times to take though!
The garage said it might be a noisey tensioner or possibley the altinator

On the other hand this is the 4th MOT ive put this car through and the only one its failed
GTVbub609 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Tags
engine , noise , spark , twin

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome