Reluctant to rev when cold - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-08-14 Thread Starter
Status: befuddled
AO Member
mattjennings's Avatar
Join Date: Jan 2014
Location: United Kingdom
County: Surrey
Posts: 35
Images: 4

Member car:

'99 GTV 2.0 TS

Reluctant to rev when cold

It's been like this for a few weeks now, but the poor thing is a total dog when cold. It gets very close to stalling when pulling away with any amount of throttle, and only really starts to get any better after a couple of minutes.

I've tried disconnecting the MAF, but this only makes it worse.

Any pointers greatly received.

mattjennings is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Jul 2004
Location: United Kingdom
County: Derbyshire
Posts: 5,591
Possibly a faulty lambda sensor.
Dave Brand is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cold , reluctant , rev

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome