spider abs light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 29-07-14 Thread Starter
Status: -
AO Member
Join Date: Aug 2011
Location: United Kingdom
County: Shropshire
Posts: 12
spider abs light

Hi everyone. My wife used to be the proud owner of a 96 spider which she has owned for many years.
For the last three years however it has sat in my drive looking sadder and sadder after it developed an immobiliser fault and wouldn't start, it never was good at starting when left for long periods. Any how after playing about with for a couple of years or so and more by luck than judgement I have got it starting brilliantly first time every time - result!!!
This brings me to my current problem - I have no ABS light so it won't pass an mot. I think this is my fault as I had to change the intstrument cluster having busted the original during my original investigations into the starting fault. I think the problem is that I was sold a phase 2 cluster being assured that it would fit. They do indeed fit, perfectly, but they do not work correctly. Having replaced it with a correct phase 1 dash I now find that I have no ABS light which I think down to the phase 2 dash. Have any of you good people got any ideas to help save this sad looking spider. I have checked all of the fuses that I find, in the car, under the bonnet, in the battery compartment and they are all intact. Somebody help please its doing my nut in.

Many thanks Mark
markesprit is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

abs , light , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome