OBD Error P0150 - O2 Sensor Circuit Malfunction (Bank 2 Sensor 1)? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-07-14 Thread Starter
Status: 17" Speedline Enzo's
Club Member
Membro Premio
Stixy's Avatar
Club Member Number: 479
Join Date: Oct 2007
Location: United Kingdom
County: Norfolk
Posts: 1,281
Images: 14
OBD Error P0150 - O2 Sensor Circuit Malfunction (Bank 2 Sensor 1)?


My Betsy, has started to run quite rich, excessive fuel consumption..

I have a slight exhaust leak on the front manifold. I've also experienced a lumpy idle. So today I got my software out & found that I had a stored error code of P0150, which translates to O2 Sensor Circuit Malfunction (Bank 2 Sensor 1). So could this be from the exhaust blowing or do I have a failed Lambda sensor or is it a combination of both? Oh and the car runs hotter than normal.

Which lambda sensor is Bank 2? By the way my engine is a CF2 unit.

GTV V6 Q2 GTA Clutch & Flywheel + Koni's + 17" Speedline Enzo's aka Betsy - Oct 07 to Present

147 JTD 8v aka Smokey - Apr 13 to Feb 14 - RIP

GT JTD 16v Remapped aka Son of Smokey - Feb 14 to Feb 16

AUDI TT 225 Quattro aka Maddie - Sept 15 to Present

Last edited by Stixy; 28-07-14 at 15:31.
Stixy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

bank , circuit , error , malfunction , obd , p0150 , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome