Oh ***** I've - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
Lardy1664's Avatar
Join Date: Jan 2007
Location: Farnborough
Posts: 41
Re: Oh ***** I've

Think even that ones a too big a job for the plastic metal

Sorry to hear your your bad news. What is the diagnosis as to why it failed?
Lardy1664 is offline  
Sponsored Links
Status: Minus an Alfa.
AO Silver Member
Pete McK's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: North Yorkshire
Posts: 1,699
Re: Oh ***** I've

Unless I've got it wrong, a complete sump including all the attachments, baffles, guards and accessories is 155 from Alfa, including the VAT.

Get another quote, FAST tried to talk a clutch change up to 650 on a car of mine.
Pete McK is offline  
Status: -
AO Member
homan's Avatar
Join Date: Jul 2006
Location: Kidderminster, Worcs
Posts: 33
Images: 4
Re: Oh ***** I've

Thanks wrinx. I think I've finally got the warranty assessor to approve it. Should have my baby back soon with a sparly new engine. *touches wood* Some kind of internal oil leak caused the engine to run dry and die I think.
homan is offline  
Status: -
AO Member
robf781's Avatar
Join Date: Oct 2006
Location: Leeds
Posts: 820

Member car:

Alfa Spider

Re: Oh ***** I've

You're pretty lucky, I hope they get it sorted for you then.
robf781 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome