Here we go again - internal fan not working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-06-14 Thread Starter
Status: -
AO Member
brispencer's Avatar
Join Date: Oct 2012
Location: United Kingdom
County: Lancashire
Posts: 386

Member car:

1999 Spider

Here we go again - internal fan not working

My fan for heating and cooling inside cabin appears to have stopped working. Where do I start looking?

Radiator changed this week so I'm wondering if there's any connectors or plugs that may need looking at.

Any advice gratefully accepted.
brispencer is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,073
Shouldn't be any connection between radiator and internal blower. Blower is located above the passenger footwell - worth checking that there is power going to it - one connector with two fairly heavy duty wires going to it. Sometimes just unplugging and reconnecting can sort it.....
rgwm is offline  
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,083
Images: 22
Two very common problems that can cause this.

Does the Fan work on full speed but not on other speeds ? If so it will be the Resistor pack, usually failure of the Thermal Fuse.

The Fan itself could be seized and just need some lubrication.

Of course it could be something to do with the Aircon system, I know nothing about that as I didn't have the luxury of Aircon in mine !

There are lots of Threads about this problem, a quick search will give you lots of info.
Nige005 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fan , internal , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome