GTV 3.0 v6 powersteering fluid missing? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 26-05-14 Thread Starter
Status: that time again
AO Platinum Member
Guili's Avatar
Join Date: Aug 2008
Location: South Africa
County: Mpumalanga
Posts: 13,681
Images: 7
GTV 3.0 v6 powersteering fluid missing?

My powersteering started making strange whining noises recently, especially when turning while stationary.

I popped the powersteering bottle cap to find the container completely dry...

I felt around the bottel, the breather pipe and all lines from it and could not feel any visble leaks.

I'll fill it up again with the correct fluid and hopefully it will be better.

where did it go though?
Guili is offline  
Sponsored Links
Status: -
AO Member
nelo1110's Avatar
Join Date: May 2008
Location: United Kingdom
County: Greater London
Posts: 273
Garage noticed my GTV was seaping power steering fluid around the actually rack. Can't remember what the exact part as 2 years ago now and once topped up it doesn't lose the fluid very at all, takes well over a year before a top up is needed.

Be interesting to know if anyone else had a leak around the rack and if the solution was major as I think the garage recommedation was replaces a good part of the rack setup.
nelo1110 is offline  
Status: Long live the nice weather
AO Silver Member
GT Paddy's Avatar
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 1,129
Check to see if a jubilee clip has not been over tightened. On mine it had cut the hose, but you could not see it unless you took the clip off.
GT Paddy is offline  
Status: -
AO Silver Member
Alfafamily's Avatar
Join Date: May 2010
Location: United Kingdom
County: Warwickshire
Posts: 5,758
Images: 10
A rack will either leak at the seal where the shaft goes into it or from the seals on the rack itself. If there is fluid inside the gaiters then the seals have failed to some degree. If it's visibly leaking it will fail an mot test. The other scenario is a leaking pipe but this would usually cause rapid fluid loss.
Alfafamily is offline  
Status: Suspension re-build complete, what next?
AO Member
GTV_Blue's Avatar
Join Date: Oct 2012
Location: United Kingdom
County: Leicestershire
Posts: 920
Images: 9

Member car:

GTV 3.0 V6 24v

I had a problem with the 90 degree elbow that bolts onto the PS pump.

See here

The part is not available and I needed to get the car on the road, so slipped a piece of rubber tube over it with silicone sealant and jubilees at each end as a "temporary repair" ........... still going 16 months later
GTV_Blue is offline  
Status: Idling at 5,000 fixed.
AO Member
daveypark's Avatar
Join Date: Feb 2006
Location: United Kingdom
County: Gloucestershire
Posts: 485
Images: 9

Member car:

GTV V6 & C220CDI

Exactly the same issue last weekend but a different solution - self tapper and silicone in the perforation and then a good coating of a two part cement. The pipe rusts through perilously thin though and I would advise anyone to coat the pipe with something to prevent further erosion.
A better fix would be to cut the pipe elbow off the banjo bolt an weld a new elbow on.

The OP should have seen the leaking fluid under the car as it drips close to where the oil cooler used to drip and was leaving a small plate sized puddle from only a tiny perforation.
daveypark is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fluid , gtv , missing , powersteering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome