Gtv v6 98 - Idle and misfiring problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 21-05-14 Thread Starter
Status: Saving my GTV!
AO Member
Mr PheR's Avatar
Join Date: Mar 2012
Location: Australia
County: South Australia
Posts: 261
Images: 4
Gtv v6 98 - Idle and misfiring problems

I am trying to sort the age old idle issue which would be a lot easier if i sent it to my mechanic. But since it is on my project car i am desperately trying to do everything myself along with the use of info and expert tips from these forums.

So far i have...

cleaned throttle body.
changed lambda sensor.
recently changed engine temp sensor, thermostat and radiator[maybe relevant]
replaced spark plugs
taped up air hose even though it doesnt have any cracks just to be sure.
timing confirmed with cam locks
checked compression on all 6 cyl.
switched the MAF from my other healthy gtv to check idle change. none
I cleaned the injectors and tested they all squirt with a 9v interdependently. But did not replaced.
I tested the front 3 coil packs by removing one at a time to see if they are contributing and all affected the idle. Due to the lack of accessibility on the rear 3 i swapped them for the front 3 then tested them from there and they all seem to contribute to idle also.

lumpy misfiring idle.
ok with cold start then worsens as it heats.
Engine, even with fans firing keeps getting hotter and goes past 90 when driving.

I know its hard to diagnose from the other side of the earth but I am really after a list of possibilities or just where i should check next.??
Mr PheR is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

gtv , idle , misfiring , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome