Help needed with intermittent electrical problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-04-14 Thread Starter
Status: -
AO Member
Join Date: Aug 2009
Location: United Kingdom
County: -
Posts: 39
Help needed with intermittent electrical problem


Got a strange one at the moment that perhaps you could opine on...electrics are not my forte.

Sometimes upon inserting the key, and turning it, code light goes out, but car does not start/turn over. This used to happen about once every hundred starts, but it's started happening more often.

Also, probably related, when I turn on anything electrical (lights, indicators, etc.) the radio cuts out for 5 seconds or so...

I'm thinking ground? Where are they located and where should I check? Any other ideas?

Thanks in advance.

quadrofig is offline  
Sponsored Links
Status: -
AO Member
tommyb's Avatar
Join Date: Jul 2011
Location: United Kingdom
County: Kent
Posts: 143

Member car:

147 GTA

Check the battery terminals.
tommyb is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

electrical , intermittent , needed , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome