V6 Power Drop when Revved Hard (with videos) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-03-14 Thread Starter
Status: -
AO Member
Join Date: Nov 2013
Location: United Kingdom
County: Greater London
Posts: 39

Member car:


V6 Power Drop when Revved Hard (with videos)

Hi All,

I am having issues when fully depressing the accelerator. In the 1st video below from idle (in neutral) I fully press the accelerator and the power dies. This situation remains with the needle either bouncing around 1,500rmp, or even registering nothing (below 500rpm?), until I lift off the gas whereby the revs approach something approaching normal.

Alfa Romeo GTV V6 Rev Die - YouTube

In this vid if I press about 50% then I can just about get the engine to rev smoothly upto the red line although even this requires delicate balance of the pedal.

Slow Rev - YouTube

This problem happens when driving. From a rolling start (about 10mph), I floor the pedal and the car will instantly respond and rev smoothly and quickly to around 6,500rpm and then die until I lift off the throttle.

Generally the car seems to idle rough. Certainly much rougher than my previous 2 Twin Sparks which were silky smooth by comparison. The car has recently had the following:

Timing Belt
(I have also performed a ECU Reset with no difference)

Both of these where done as soon as I bought the car and so I have no benchmark to compare to before these items were replaced. The car has no lights on the dash and I have plugged it in to the laptop which shows no error codes.

I have been researching this all day and I have seen similar threads with issues ranging from Cats, water, bad earth, faulty MAF. From these vids can anybody narrow this down a little?

wiv1728 is offline  
Sponsored Links
Status: Bring on the Giulia
AO Platinum Member
OperationAlfa's Avatar
Join Date: May 2007
Location: United Kingdom
County: Essex
Posts: 23,176
Is that a genuine MAF you are using? Disconnect it and try again.

Also I'd advise against redlining it too much when not on the move.
OperationAlfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

drop , hard , power , power or acceleration , revved , rough or jerky , videos

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome