1997 GTV speedo cuts out temporarily with fan - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 31-10-06 Thread Starter
Status: -
AO Member
GILLK's Avatar
Join Date: Oct 2006
Posts: 20

Member car:


1997 GTV speedo cuts out temporarily with fan

Hi just wondering if anyone else has experienced similar... my speedo cuts out for a split second When the rad fan turns on also if the headlights are on they dim slightly. Im not too bothered about this but was wondering if it can become a bigger problem and if anyone knows what could cause this and how to cure it??
GILLK is offline  
Sponsored Links
Status: -
AO Member
nosbork's Avatar
Join Date: Jun 2006
Location: Grantham, Lincs
Posts: 317
Images: 1

Member car:

Gtv 2.0 TS Lusso

Re: 1997 GTV speedo cuts out temporarily with fan

I had a similar problem when I switched my lights onto main beam, the radio would cut out for a second or two, turned out to be a loose battery earth lead where it is bolted to the body.
nosbork is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

1997 , cuts , fan , gtv , speedo , temporarily

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome