Heater Fan - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-02-14 Thread Starter
Status: -
AO Member
Join Date: Feb 2012
Location: United Kingdom
County: -
Posts: 108

Member car:

P3 GTV 2.0 JTS

Heater Fan


The other week I had a brief episode where my internal fan stopped working, the heater still works but not the fan. After a 10 minutes or so it came back on and worked normally...

Until I was driving my mother through the Beacons, full snow very, very cold, at which pint the little bugger packed up. So I had to drive with the window open to stop the car from misting up.

Any ideas about what'd cause this, is it a common problem?
Oldrover is offline  
Sponsored Links
Status: profesional ledgend
AO Silver Member
bradpit999's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: West Midlands
Posts: 2,280
Images: 42
The heater motor is just behind the glove box and in the passenger foot well, mine sometimes makes a noise like its getting old i just tap it and it goes away, You can see the motor itself if you remove the passenger scuttle panel and you could see if you have debris in there, there is supposed to be protective panel mounted over this ........................ operative word there is "supposed" to be
bradpit999 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fan , heater

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome