GTV 2.0ts ph1 normal idle speed? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 02-02-14 Thread Starter
Status: -
Join Date: Jan 2014
Location: United Kingdom
County: Leicestershire
Posts: 8

Member car:

GTV 2.0 TS

GTV 2.0ts ph1 normal idle speed?

New owner of a GTV 2.0ts phase 1 & i was wondering what the normal idle speed is, as the idle speed i have been getting is around 1200 & i thought this might be a bit high?
AdeShades is offline  
Sponsored Links
Status: -
AO Silver Member
00Alfa Andy's Avatar
Join Date: Aug 2010
Location: United Kingdom
County: Kent
Posts: 4,300
Images: 45

Member car:


Hi, welcome to the fold

Tick over should be aroung 800 rpm, my ph1 Spider has a light weight flywheel fitted as ticks over at 500rpm. It does vary with different cars.

Have a look at the rubber hoses in the intake system as these tend to perish and split.
00Alfa Andy is offline  
Status: Planning the next project ...
AO Silver Member
Join Date: May 2007
Location: United Kingdom
County: Bedfordshire
Posts: 3,953
Official figure is 850 +/-30. It'll be higher when the engine is cold.

Idle speed will also vary with electrical load. Ensure everything possible is switched off to get a more accurate picture ( lights, wipers, HRW, heater fan, A/C, radio etc ).
pkr is offline  
(Post Link) post #4 of 5 Old 06-02-14 Thread Starter
Status: -
Join Date: Jan 2014
Location: United Kingdom
County: Leicestershire
Posts: 8

Member car:

GTV 2.0 TS

Thanks for the replies.
I've taken the car out for a few drives since & the idle is around 800 at start up but then goes up to 1200 pretty soon after, this is driving at night with lights, heater on & driving in the day with no other electrics on.
The car hasn't been serviced in two years but i've got it booked in for tomorrow morning & am going to get the garage to have a look whist it's being serviced.
AdeShades is offline  
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
It's probably the Idle Control Valve.

If your donkey is a CF1 (alloy top..?) then you can take it off and clean the inner rotary valve out with carb' cleaner (or electrical contact cleaner) etc. The valve is metal and should rotate, so it you see a horrible black mess of gunge in there, then you have to dissolve it off.

Don't force the valive to turn with a screwdriver etc. Just spray out the gunge then work the valve gently to free it all off. Roberto is your mother's brother.

Don't use de-greaser... it's a bit tooo fierce.

Ralf S.

No bullets for Chaingun..
Ralf S. is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

20ts , gtv , idle , normal , ph1 , speed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome