Cooling fan coming on with injector light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 15-01-14 Thread Starter
Status: -
AO Member
Join Date: Jan 2008
Posts: 29

Member car:

GTV 3.0 V6 24v

Cooling fan coming on with injector light

Morning all

Hoping for some help with this dilemma as I've read most posts on this and still no joy.

I've got a Ph2 V6 and the injector light keeps coming on, mainly if I rev past 5k. Once on, it stays on despite switching ignition off and on again. Then shortly after the cooling fan kicks in no matter what the temperature gauge is showing (most often it's around 60 so not even 'hot'). The car feels quite lumpy, and sometimes pulling away from standstill is slightly delayed (not fun when trying to get off my roundabout!). Then when I switch off and switch on again I have to give it extra throttle like an old carb car because it won't start on it's own (ignition light still on). The more times I turn her on the less likely she is to start to a point where she won't start at all.

Don't know what to look at first. Have cleaned out the MAF which cured it for a few miles only.

Cheers in advance
srdenny is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

coming , cooling , fan , injector , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome