Engine light - AGAIN - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-07-06 Thread Starter
Status: -
AO Member
chriscrane's Avatar
Join Date: Mar 2006
Location: Southampton
Posts: 48
Engine light - AGAIN

I posted a while ago about the engine warning light coming on. Took the car to a 'specialist' who couldn't recognise the code, so re-set it and told me to come back if it comes on again. Guess what? It's back!
The only difference I notice is a brief yet strong smell of petrol when in start/stop traffic or multiple speed changes (ie 60mph to 30mph to stop, then up to 30mph etc due to traffic).
Could this be because one of the sensors if telling the ECU to squirt far to much fuel in due to rev changes (hence the smell), then the ECU settles down and amends the mix (and the smell goes?). Would this be the MAF or the O2 sensors in teh exhaust area? If so, anybody know how easy they are to DIY replace?

Thanks for any further help guys n' gals!

"Don't do that Luke. She could be your sister."
chriscrane is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Engine light - AGAIN

I'd go for the AFM as 3.0 cars are known for eating them.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

engine , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome