GTV back on the road after 18 months... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 07-11-13 Thread Starter
Status: -
AO Member
RS232's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Wiltshire
Posts: 432

Member car:

Alfa 156 2.4JTD

GTV back on the road after 18 months...

Yes, it's back on the road
Failed MOT on break efficiency but that was due to new break pads/discs and not been driven (passed second time)
Back on the road and had first "scare" today, car died completely exiting a roundabout.
Dead, nothing worked, no engine no electrics, not a simple light on the dash...
Stopped in a Bus stop and it took me a full 10 seconds to figure out what it was and popped the boot to check on the battery and there it was, I forgot to bolt the battery bracket and it slip shorting the positive to ground on the bracket plate.
Lucky for me the battery wasn't in a good shape and nothing serious append, no smoke or fire but had to jump start the car do drive home.
New battery and problem sorted the old one died with the short to ground.
Very happy with the GTV but still new to finish a couple of things...


PS. New battery is safely secured/bolted and is not going anywhere.
RS232 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

back , gtv , months , road

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome