Broken track rod end? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 07-11-13 Thread Starter
Status: -
AO Member
 
alfa166man's Avatar
 
Join Date: Sep 2008
Location: United Kingdom
County: Orkney Islands
Posts: 225
Broken track rod end?

Heading along the road yesterday i heard a strange noise something snapping or breaking.

steering was pulling left and knocking under breaking, strange noise when turning which i later discovered was the right front wheel rubbing on the inner arch.

first i though a spring had collapsed but now i think track rod end has broken. waiting for the garage to collect it now but looking for some confirmation or ideas from you fine folks!

just was at the car now and the front right wheel is sitting a lot further forward thank the other front wheel.

am i on the right path here?
alfa166man is offline  
Sponsored Links
Advertisement
 
pkr
Status: Planning the next project ...
AO Silver Member
 
Join Date: May 2007
Location: United Kingdom
County: Bedfordshire
Posts: 3,995
Quote:
Originally Posted by alfa166man View Post
steering was pulling left and knocking under breaking, strange noise when turning which i later discovered was the right front wheel rubbing on the inner arch.
You didn't stop immediately and investigate? You just carried on?

Lower wishbone would be the first thing I'd look at.
pkr is offline  
(Post Link) post #3 of 8 Old 07-11-13 Thread Starter
Status: -
AO Member
 
alfa166man's Avatar
 
Join Date: Sep 2008
Location: United Kingdom
County: Orkney Islands
Posts: 225
Sadly couldn't just stop as was on a busy stretch of road, got it as far as my work place, wishbone was replaced only a few months ago though.
alfa166man is offline  
(Post Link) post #4 of 8 Old 07-11-13 Thread Starter
Status: -
AO Member
 
alfa166man's Avatar
 
Join Date: Sep 2008
Location: United Kingdom
County: Orkney Islands
Posts: 225
IMG_20131107_143110.jpg
Quote:
Originally Posted by alfa166man View Post
Sadly couldn't just stop as was on a busy stretch of road, got it as far as my work place, wishbone was replaced only a few months ago though.
Picture of wheel
alfa166man is offline  
Status: V6 Inside
AO Silver Member
 
ransoman's Avatar
 
Join Date: Jan 2007
Location: United Kingdom
County: Aberdeenshire
Posts: 4,745
Images: 1
Jack it up and get the wheel off. It will be pretty obvious what the failed component is.
ransoman is offline  
(Post Link) post #6 of 8 Old 07-11-13 Thread Starter
Status: -
AO Member
 
alfa166man's Avatar
 
Join Date: Sep 2008
Location: United Kingdom
County: Orkney Islands
Posts: 225
Wishbone it is, garage I had it at failed to attach one of the bolts! So they are paying to sort it.
alfa166man is offline  
Status: Sorry darkside s2000
AO Member
 
Join Date: Sep 2009
Location: United Kingdom
County: Edinburgh
Posts: 708

Member car:

alfa spider

Better not going back there then once fixed
I would check to see if anymore damage has been caused before taking away
MIKE GILL is offline  
(Post Link) post #8 of 8 Old 07-11-13 Thread Starter
Status: -
AO Member
 
alfa166man's Avatar
 
Join Date: Sep 2008
Location: United Kingdom
County: Orkney Islands
Posts: 225
It's not actually at that garage, it's at the one I usually use, bill is being sent elsewhere though! They have had a good look though and everything else is ok thankfully!
alfa166man is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Tags
broken , end , rod , track

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome