916s 2.0 TS slow to fire up - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-10-13 Thread Starter
Status: -
Join Date: Mar 2013
Location: Isle of Man
County: -
Posts: 3

Member car:

Alfa Spider

916s 2.0 TS slow to fire up

I purchased a 1996 916s, all was ok until I had the timing belt, tensioners etc plus the water pump and thermostat replaced. Since then my car has struggled to start. It turns over fine but struggles to fire up, it eventually spluters into life.
Once started it behaves itself, with one exception, occasionally when slowing down and depressing the clutch, the revs completely die and then then it comes back to life.
All very strange.
It has had new plugs, and, over the weekend I removed the battery to charge, then performed the much publicised ECU and throttle reset.
This has had no effect with the starting.
Help, does anyone have any advice?
Kind regards
IOM Alfa is offline  
Sponsored Links
Status: Planning summer upgrades
AO Member
AussieAlex's Avatar
Join Date: Feb 2013
Location: Aussie in Sweden
County: Stockholm
Posts: 742
Images: 12
Seems like a lambda issue potentially? Have a read through this thread as it seems very similar to your issue;

AussieAlex is offline  
Status: In an Alfa again!
AO Member
Mark Cooper's Avatar
Join Date: Jun 2012
Location: South Africa
County: KwaZulu-Natal
Posts: 619
Check your cam position sensor as well.
Mark Cooper is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

916s , fire , slow

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome