hello to all, Lovce car BUT Spider Aerial wont raise! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 15-05-06 Thread Starter
Status: -
Join Date: Apr 2006
Posts: 1
hello to all, Lovce car BUT Spider Aerial wont raise!

Afternoon Fellas,

Newbie to the forum, having picked up my Spider last Friday! Wow what a car and very very happy!

Its a 2000(X) Red 2.0, with 35k on the clock.... and it's love! will post pics soon, the previous owner has modded it but so so well that rather than looking like fast and furious gone wrong, in my opinion he has improved upon the original!

It has silver hoops, clear side indicators, silver handbrake, silver gearknob, Chrome exhaust and beautiful 5 spoke alloys with alfa logo! Just love the car, true sports car!

A couple of issues...... the aerial worked fine on drive home from where i bought it in Bristol, but then the next day the electrical aerial wouldnt raise and hasnt since!! Typical! checked wiring and all seems okay, any ideas?

One other thing, is gear knob, its clearly been added and is slightly scratched, I would like to replace it, it is just a silver ball basically, will any one fit? or do i need to be careful? and any ideas where i might find one?

Thanks Guys! Much appreciated!
Althepsiderman is offline  
Sponsored Links
Status: Brera 2.4 jtd 500 abarth
AO Member
alfatwice's Avatar
Join Date: Mar 2006
Location: wickford essex
Posts: 910
Thumbs Up Re: hello to all, Lovce car BUT Spider Aerial wont raise!

hi from fellow newbie cant help with the gear nob but most just pull off .the electric ariel is not worth messing with go to ebay alfa parts you can get a new one for 26 GOOD LUCK
alfatwice is offline  
Status: -
AO Member
Join Date: Apr 2006
Location: Welling, Kent
Posts: 27
Re: hello to all, Lovce car BUT Spider Aerial wont raise!

It is not necessarily the aerial at fault. I changed the head unit in my Spider from the factory fitted alfa unit to a Pioneer one. The aerial would not function with the Pioneer head unit originally, when I changed back the head unit to the original, it then functioned, did this a couple of times checked my wiring, left scratching my head (seemed the electric aerial was not seeing the Pioneer head unit when powered). To cut a long story short, I knackered a relay looking for a solution (got a little heavyhanded), took it to an audio / alarm specialist who then fitted the head unit and changed the relay. The electric aerial now works with the Pioneer as soon as the head unit is turned on. No idea what the specialist altered, but you may find you buy a new aerial and still have the problem?
Jameslondon is offline  
Status: - Update
Posts: n/a
Re: hello to all, Lovce car BUT Spider Aerial wont raise!

They are a bit of a problem on Spider/GTVs...recently replaced ours. There are a few threads in the Spider/GTV lounge about this, including places to buy the aerial...have a look

Status: -
AO Platinum Member
Gary Slegg's Avatar
Join Date: Feb 2006
Location: North Wales
Posts: 16,710
Re: hello to all, Lovce car BUT Spider Aerial wont raise!

Remember to oil the new one
Gary Slegg is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

aerial , car , lovce , raise , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome