GTV on Track, Fuel Pump whine. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 30-08-13 Thread Starter
Status: -
AO Member
nelo1110's Avatar
Join Date: May 2008
Location: United Kingdom
County: Greater London
Posts: 273
GTV on Track, Fuel Pump whine.

Yesterday the GTV spent the morning at Brands Hatch.

Was the only Italian car amonst the French, German and Japanese metal but took it all in it's stride, only a couple were older too.

Car rolled a bit but stuck to the track well although I made the mistake of putting on P6000's which squealled on the tight corners quite badly. Next time I will stick with my normal road tyres as wear wasn't a problem in the 2.5 hours of track time.

It was an open pit lane set-up so I would do 10-15 laps then pop back in to rest the car ( and me ). Had cones for braking, apex and exit and lots of marshalls watching over.

I had new regular brake fluid and it was fine, although only 3 corners than I broke hard on ( abs kicked it ). Okay I wasn't doing the best braking practice.

Only when the track day ended and I was driving back into the pits I noticed a loud whine from the rear, was like the fuel pump whine but much louder, wonder if anyone else has noticed their fuel pump making a loud noise? the tank was on the quarter mark by now. I was thinking it could have been heat expansion or the fuel level was low enough to starve the fuel as I took corners.

After a lunch break and watching the race cars in the afternoon session ( 1 hour ) the whinning had stopped and the journey home was fine.

Can't wait to put on the right tyres and do it again some day.

Had some photos taken but the shutter speed was so high the car always looks stationary

Noise test was only around 80db with a track limit of 105db I was quite compared to the competition, unsual for the v6
nelo1110 is offline  
Sponsored Links
Status: no car yet, house 1st!!!!
AO Member
darren1968's Avatar
Join Date: Jun 2012
Location: United Kingdom
County: Kent
Posts: 164

Member car:

wifes punto!

Nice one, Brands is a great little circuit
Had my old GTV V6 TB on there a few years back.
Only done a few flying laps as I didn't check my brake pads before and ended up with flames coming out of the front wheels and got black flaged completely ruined my Red-Dot discs & drove home with no brakes that day
darren1968 is offline  
(Post Link) post #3 of 3 Old 01-09-13 Thread Starter
Status: -
AO Member
nelo1110's Avatar
Join Date: May 2008
Location: United Kingdom
County: Greater London
Posts: 273
No photos of burning brake pads I'm afraid Darren
Attached Images
File Type: jpg IMG_5516.jpg (67.3 KB, 8 views)
File Type: jpg IMG_5886.jpg (66.6 KB, 6 views)
File Type: jpg IMG_6013.jpg (91.0 KB, 6 views)
nelo1110 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fuel , gtv , pump , track , whine

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome